Cache edge degraded performance

Incident Report for DNSimple

Resolved

This incident has been resolved.
Posted Jan 29, 2026 - 17:58 UTC

Update

Cache edge performance has been stable for some time, and we have seen no further issues.

We keep monitoring the situation
Posted Jan 29, 2026 - 17:20 UTC

Monitoring

We are observing degraded performance at our cache edge nodes, which may impact request latency for some users.

Our team is actively investigating the cause and working to mitigate the issue.
Posted Jan 29, 2026 - 16:52 UTC
This incident affected: Name Servers.