Domain registrar issues
Incident Report for DNSimple
Resolved
This incident has been resolved.
Posted Feb 17, 2020 - 21:57 UTC
Investigating
One of our upstream providers for domain registration is currently having issues with their system. This is resulting in intermittent failures in domain registrations and other domain operations for certain TLDs.

We are currently awaiting a fix from them and will provide updates as we have them.
Posted Feb 17, 2020 - 21:00 UTC
This incident affected: Registrar.