DNS zone distribution delays

Incident Report for DNSimple

Resolved

Distribution across all zones is now back to normal.
Posted Apr 01, 2025 - 11:34 UTC

Identified

We are currently addressing delays in DNS zone updates across some data centers. The issue only affects a small portion of zones.
Posted Apr 01, 2025 - 10:41 UTC
This incident affected: Name Servers.