Multi-year Comodo SSL certificate purchase/renewal error
Incident Report for DNSimple
Resolved
We deployed the changes to the UI to limit the period to 2 years, and the documentation has been updated accordingly.
Posted Mar 14, 2018 - 18:09 UTC
Identified
Maximum certificate expiration has been decreased by the CA/B forum as a result of Ballot 193
https://cabforum.org/2017/03/17/ballot-193-825-day-certificate-lifetimes/

We are updating our documentation and site accordingly.
Posted Mar 14, 2018 - 17:26 UTC
Investigating
Multi-year Comodo certificate purchases are currently failing with error "This quantity is not allowed for this account". We contacted the upstream provider and we will update this thread as soon as we have more information.
Posted Mar 14, 2018 - 13:08 UTC