Contact form issues
Incident Report for DNSimple
Resolved
The issues with our contact form at https://dnsimple.com/contact have been fully resolved. If you attempted to contact us in the last 24 hours and did not receive a response, please email us again at https://dnsimple.com/contact.
Posted Jul 04, 2024 - 10:10 UTC
Monitoring
We have resolved the issues with our contact form at https://dnsimple.com/contact and are now monitoring the situation to ensure everything is working correctly. Unfortunately, any emails sent to us through the contact form in the last 24 hours were not received. If you contacted us during that time, please reach out again through https://dnsimple.com/contact or directly at support@dnsimple.com. We apologize for the inconvenience and appreciate your understanding.
Posted Jul 04, 2024 - 09:27 UTC
Investigating
We are currently experiencing issues with our contact form at https://dnsimple.com/contact. If you need support, please contact us directly at support@dnsimple.com. We apologize for the inconvenience and are working to resolve the issue as quickly as possible. Thank you for your understanding.
Posted Jul 04, 2024 - 08:58 UTC
This incident affected: Website.