Network Performance Issues

Incident Report for DNSimple

Resolved

No further service degradation has been observed for the past 3 hours. We consider this incident resolved.
Posted Nov 25, 2024 - 06:25 UTC

Monitoring

We have identified the source of the issue, and we have implemented performance optimization measures to ensure stability and service continuity.

We will continue to monitor the network and update this page with the latest information as we continue to monitor for network conditions to return to normal. Thank you for your patience and understanding.
Posted Nov 25, 2024 - 03:40 UTC

Investigating

We are currently experiencing network performance issues affecting our DNS response times. Our team is actively investigating the cause of the disruption and working to restore optimal performance as quickly as possible.

We will continue to update this page with the latest information as we work towards a resolution. Thank you for your patience and understanding.
Posted Nov 25, 2024 - 03:14 UTC
This incident affected: Name Servers.