dnsimple.com availability issues

Incident Report for DNSimple

Resolved

This incident has been resolved.
Posted Apr 20, 2026 - 21:44 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 20, 2026 - 20:43 UTC

Identified

We've identified the issue and are continuing to mitigate the impact
Posted Apr 20, 2026 - 20:21 UTC

Update

We are continuing to investigate this issue.
Posted Apr 20, 2026 - 20:07 UTC

Investigating

We are investigating an issue reaching dnsimple.com

We will provide an update shortly

Thank you for your patience and understanding.
Posted Apr 20, 2026 - 19:54 UTC
This incident affected: Website, API, URL Redirector, Webhooks, and Notifications.