Sporadic DNS resolution issues on zone with DNSSEC enabled

Incident Report for DNSimple

Resolved

This incident has been resolved.
Posted Jun 09, 2025 - 14:59 UTC

Monitoring

The rollback has completed.

The nameservers that were previously returning invalid data are serving now correct responses.

It might take up to the TTL value of the corresponding records to clear out cached responses.
Posted Jun 09, 2025 - 13:59 UTC

Update

We are rolling back a recent deployment to a stable version of our nameservers
Posted Jun 09, 2025 - 13:38 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jun 09, 2025 - 13:35 UTC

Identified

We are currently investigating an issue while certain DNSSEC-enabled zones are sporadically returning SERVFAIL.
Zones without DNSSEC are not affected.
Posted Jun 09, 2025 - 13:33 UTC
This incident affected: Name Servers.