Elevated latencies for DNS queries

Incident Report for DNSimple

Resolved

The issue has been fully resolved. Services are back to normal.
Posted Dec 01, 2025 - 15:36 UTC

Monitoring

We have identified the issue and implemented fixes. Systems are recovering and performance is returning to normal.
Posted Dec 01, 2025 - 13:10 UTC

Investigating

We are currently experiencing issues with our cache edge, which may cause increased latency for some queries. Our team is actively investigating and implementing mitigations.
Posted Dec 01, 2025 - 12:54 UTC
This incident affected: Name Servers.