Commercial certificate issuance delays
Incident Report for DNSimple
Resolved
Sectigo has solved the issue. Commercial certificate issuance is operational again.
Posted Oct 07, 2024 - 15:01 UTC
Update
We are continuing to work on a fix for this issue.
Posted Oct 07, 2024 - 14:17 UTC
Identified
One of our SSL Certificate providers is currently experiencing issues. That will delay issuance of commercial certificates. Please, see https://sectigo.status.io for more details.

Let'sEncrypt certificates are not affected.
Posted Oct 07, 2024 - 14:16 UTC
This incident affected: SSL Certificates.