DNS propagation delays
Incident Report for DNSimple
Resolved
We see no further re-occurrences of this issue at this time. If you have any problems please email us at support@dnsimple.com
Posted Oct 10, 2019 - 02:22 UTC
Monitoring
Our system detected an issue with the propagation of DNS records created, deleted or updated between 00:50 UTC and 00:55 UTC. We have identified and corrected the situation. DNS records affected by this issue have been correctly propagated.

We continue to monitor the propagation of DNS records at the present time.
Posted Oct 10, 2019 - 01:56 UTC