Edge network disruption in Warsaw EU region

Incident Report for DNSimple

Resolved

The issue was resolved upstream, and the Warsaw region has been stable.
Posted Sep 06, 2026 - 15:55 UTC

Investigating

Our Warsaw EU region is experiencing local network issues. We are investigating the issue.

The only impact on our service is slightly higher latency in the region, as traffic is routed to our nearby regions in Europe.
Posted Sep 06, 2026 - 13:10 UTC
This incident affected: Name Servers.