Email forwarding issues

Incident Report for DNSimple

Resolved

This incident has been resolved.
Posted Jul 18, 2025 - 15:34 UTC

Update

We have fixed the root cause and our team is consolidating the existing email forward configurations in our upstream partner.
Posted Jul 18, 2025 - 13:00 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 18, 2025 - 08:10 UTC

Investigating

We’re currently experiencing problems with email forwarding delivery to a subset of users. We are investigating the root cause and will post updates as soon as we have more information.
Posted Jul 18, 2025 - 05:00 UTC
This incident affected: Email Forwards.