Upstream Registrar Issues

Incident Report for DNSimple

Resolved

The incident has now been resolved. The system is now operational.
Posted Jul 04, 2025 - 06:33 UTC

Monitoring

System has been stabilized and we are monitoring the results.
Posted Jul 04, 2025 - 03:22 UTC

Update

Work toward a resolution is still underway. We keep monitoring our upstream partner status page, and we'll post updates here.
Posted Jul 04, 2025 - 01:28 UTC

Update

Our upstream registrar partner is still working on a solution

We keep monitoring their status page, and we'll post updates here.
Posted Jul 03, 2025 - 22:32 UTC

Identified

Our upstream registrar partner is experiencing a downtime.

This may result in certain registrar operations being delayed or unable to complete. We are monitoring their status page, and we'll post updates here.

DNS resolution is not affected.
Posted Jul 03, 2025 - 19:25 UTC
This incident affected: Registrar.