Comodo SSL Certificate System Issues
Incident Report for DNSimple
Resolved
It appears this issue is now resolved.
Posted Apr 17, 2018 - 00:47 UTC
Identified
We have identified an issue with our upstream provider for Comodo SSL certificates. We have notified our provider of this issue and are awaiting a fix from them. This impacts both new certificates and certificate renewals.
Posted Apr 16, 2018 - 18:08 UTC