Upstream Registrar Issues
Incident Report for DNSimple
Resolved
The upstream provider is fully operational. This incident has been resolved.
Posted Nov 18, 2023 - 23:00 UTC
Monitoring
A fix has been implemented by our upstream registrar, and we are monitoring the results.
Posted Nov 18, 2023 - 22:44 UTC
Identified
One of our upstream registrar partners is experiencing downtime.

This may result in certain registrar operations being delayed or unable to complete. We are monitoring their status page, and we'll post updates here.

DNS resolution is not affected.
Posted Nov 18, 2023 - 22:30 UTC
This incident affected: Registrar.