Site is offline
Incident Report for DNSimple
Resolved
This incident has been resolved. We have closely monitored the situation and all services are running as expected.
Posted Nov 30, 2023 - 22:32 UTC
Monitoring
We finished processing the updates and we are actively monitoring the situation.
Posted Nov 30, 2023 - 21:55 UTC
Update
We are continuing to process the pending updates. 4 regions are currently running 30 minutes behind: IAD, ORD, SV1, AMS. We expect them to complete in the next 10 minutes.
Posted Nov 30, 2023 - 21:30 UTC
Identified
We have identified and corrected the issue. The connection is restored and the app is back online. We are working to process the pending updates at the edges.
Posted Nov 30, 2023 - 20:52 UTC
Update
We found an abnormal number of connections to our primary database, that is saturating the connection pool. We are working to restore the connectivity from the app to the database. DNS resolution is not affected, however new changes to DNS records are currently not propagating to the edges.
Posted Nov 30, 2023 - 20:39 UTC
Update
We are continuing to investigate this issue.
Posted Nov 30, 2023 - 20:27 UTC
Investigating
We are currently investigating a database issue that is affecting the main application. DNS resolution is currently not affected.
Posted Nov 30, 2023 - 20:18 UTC
This incident affected: Website, API, and URL Redirector.