Delays on issuing Comodo certificates
Incident Report for DNSimple
Resolved
This incident has been resolved.
Posted Oct 02, 2020 - 22:40 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 02, 2020 - 18:55 UTC
Update
We are continuing to work with our providers on this matter
Posted Oct 01, 2020 - 22:30 UTC
Identified
We have identified an issue with our upstream provider for Comodo SSL certificates. We have notified our provider of this issue and are awaiting a fix from them. This impacts both new certificates and certificate renewals.
Posted Sep 30, 2020 - 23:30 UTC
This incident affected: SSL Certificates.