DNS Resolution Issues in IAD
Incident Report for DNSimple
Resolved
Traffic has stabilized and responses are returning normally. If you experience any issues please contact us at support@dnsimple.com
Posted May 14, 2021 - 17:09 UTC
Investigating
We are currently investigating an issue with DNS resolution affecting our IAD data center causing degraded performance.
Posted May 14, 2021 - 16:47 UTC
This incident affected: Name Servers.