Traffic spike across all DCs
Incident Report for DNSimple
Resolved
Traffic levels are back to normal.
Posted May 29, 2024 - 13:53 UTC
Investigating
We are seeing an uncommon traffic pattern across all our data centers. We are currently investigating.
Posted May 29, 2024 - 12:52 UTC
This incident affected: Name Servers.