Network Performance Issues
Incident Report for DNSimple
Resolved
This incident has been resolved.
Posted Nov 27, 2024 - 20:16 UTC
Identified
We have identified the source of the issue, and we have implemented performance optimization measures to ensure stability and service continuity.

We will continue to monitor the network and update this page with the latest information as we continue to monitor for network conditions to return to normal. Thank you for your patience and understanding.
Posted Nov 27, 2024 - 17:04 UTC
This incident affected: Name Servers.