Network Performance Issues

Incident Report for DNSimple

Resolved

This incident has been resolved. If you see any further issues, please let us know at support@dnsimple.com
Posted Apr 08, 2025 - 02:57 UTC

Update

We are not seeing any more errors or issues, but are closely monitoring the situation.
If you are still seeing any issues, please reach out at support@dnsimple.com
Posted Apr 08, 2025 - 02:39 UTC

Monitoring

We have implemented several mitigations and are seeing significantly reduced errors. We are working to resolve any remaining issues quickly.
Posted Apr 08, 2025 - 02:21 UTC

Identified

We are still under a significant network DDoS and are working to mitigate it in several areas.
Posted Apr 08, 2025 - 01:16 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 08, 2025 - 00:18 UTC

Identified

We have identified the source of the issue, and we have implemented performance optimization measures to ensure stability and service continuity.

We will continue to monitor the network and update this page with the latest information as we continue to monitor for network conditions to return to normal. Thank you for your patience and understanding.
Posted Apr 07, 2025 - 23:46 UTC
This incident affected: Name Servers.