Issues with domain registrations
Incident Report for DNSimple
Resolved
The issue has been resolved and all the pending registrations as been processed.
Posted Aug 08, 2018 - 16:32 UTC
Investigating
New registrations may fail with "Bad request". Our upstream provider is currently having an issue that is preventing new registrations to complete. We are monitoring the issue and we'll provide an update as soon as we have news. We will automatically re-attempt the failed registrations once the issue resolves.
Posted Aug 08, 2018 - 15:35 UTC
This incident affected: Registrar.