Email Delivery Issues

Incident Report for DNSimple

Resolved

We’ve traced the email delivery failures to hard bounces and automatic suppressions affecting specific recipient addresses. We're resolving this incident.
Posted May 16, 2025 - 08:56 UTC

Investigating

We’re currently experiencing problems sending transactional and notification emails to a subset of users. Messages to affected addresses may be delayed or fail to arrive. Our team is investigating the root cause with our email provider and will post updates as soon as we have more information.

Thanks for your patience while we work to restore full delivery.
Posted May 16, 2025 - 08:35 UTC
This incident affected: Notifications.